Not able to log in? [Solution available]

Discussion in 'Admin/Mod Help Forum' started by SwansonsTache, Jan 1, 2017.

  1. Jan 1, 2017
    #1

    SwansonsTache incontinent sexual deviant & German sausage lover

    Joined:
    Dec 16, 2015
    Messages:
    10,445
    Location:
    Norway
    So yeah, that just happened.

    Got logged out and when I click the login button the page refresh but nothing happens.

    When I click the members tab I get logged in again, but as soon as I return to forum index the problem returns.

    ---------------------

    (edited by Niall)

    Solution:

    This is a cookie issue. First try logging out by visiting http://www.redcafe.net/logout and then log back in again.

    If that doesn't work, clear cookies for this site in your browser and you should be able to login.

    Clearing cookies in Chrome or Firefox on a desktop (thanks to @fishfingers15):
    Clearing cookies in Safari on iOS (thanks to @Moonred):
    Clearing cookies in Chrome on Android (thanks to @diarm):


    The source of this bug was found and fixed. But if you're experiencing problems with staying logged in, please post in this thread.
    Last edited by a moderator: Jan 25, 2017
  2. Jan 1, 2017
    #2

    SwansonsTache incontinent sexual deviant & German sausage lover

    Joined:
    Dec 16, 2015
    Messages:
    10,445
    Location:
    Norway
    Worked now that I took the route through my user profile, clicked on recent activity and tried to access on of my posts in the General.

    Got prompted the login page which I couldn't access through the forum index page \ front page.
  3. Jan 1, 2017
    #3

    Scrumpet There are no words

    Joined:
    Aug 24, 2010
    Messages:
    24,065
    Location:
    Froggle Rock
    Same here
  4. Jan 1, 2017
    #4

    Akshay Moderator

    Joined:
    Jun 14, 2014
    Messages:
    8,471
    Location:
    A base camp for the last, final assault
    Had this problem earlier. Luckily had a thread open which redirected me to the login page.
  5. Jan 1, 2017
    #5

    Niall All Powerful Super Being

    Joined:
    Jun 13, 1999
    Messages:
    14,355
    Hmm, that's odd. @SwansonsTache I'm trying to replicate this in Firefox (v47 on Mac) but so far no issue with being logged out. Is it still happening?

    Anyone else having this problem?
  6. Jan 1, 2017
    #6

    SwansonsTache incontinent sexual deviant & German sausage lover

    Joined:
    Dec 16, 2015
    Messages:
    10,445
    Location:
    Norway
    It worked after I logged in through the method explained above. Haven't had the problem since.
  7. Jan 1, 2017
    #7

    maba723 likes bananas a bit too much

    Joined:
    Jun 28, 2011
    Messages:
    2,053
    Used to happen to me. It used to work when I ticked 'Stay logged in'

    EDIT: I see what you're talking about. same thing just happened to me after posting this. Page just refreshes
    I'm on mobile and if I click on any link, I'm logged in. When I click on the 'redcafe' banner, I'm logged out and then I encounter the problem
    Last edited: Jan 1, 2017
  8. Jan 1, 2017
    #8

    Balu Full Member

    Joined:
    Dec 2, 2010
    Messages:
    14,884
    Location:
    Munich
    Supports:
    Bayern Munich
    I just had the excact same problem on my windows 10 notebook with Firefox v50.1.0 . Was logged out on all the forum pages and clicking on the login button just refreshed the page, but didn't forward me to the login page. Solved it as written above, went to my own profile page (where I strangely was still logged in), clicked on logout, tried to access my profile again and was forwarded to the login page.
  9. Jan 1, 2017
    #9

    Niall All Powerful Super Being

    Joined:
    Jun 13, 1999
    Messages:
    14,355
    I've made a couple of changes, specifically around the login link not taking you to the login page. I'm not sure why you're getting randomly logged out though.

    Please let me know if you're still having issues @Balu @maba723 @SwansonsTache @Scrumpet @Akshay.
  10. Jan 1, 2017
    #10

    coolredwine lameredboots

    Joined:
    Aug 11, 2011
    Messages:
    14,994
    Location:
    Je m'en fous!
    I'm seeing this issue on Safari. Every time I click the log in button, the page just keeps getting refreshed. Working fine on Chrome though.

    @Niall
  11. Jan 1, 2017
    #11

    Tarrou Full Member

    Joined:
    May 13, 2013
    Messages:
    10,245
    Location:
    Malta (4 years ago - I'm not Maltese)
    Firefox? lol
  12. Jan 1, 2017
    #12

    Niall All Powerful Super Being

    Joined:
    Jun 13, 1999
    Messages:
    14,355
    This is possibly a caching issue. Can you clear your cache on safari and see is that helps?

    http://osxdaily.com/2016/01/17/empty-cache-safari-mac-os-x/
  13. Jan 1, 2017
    #13

    coolredwine lameredboots

    Joined:
    Aug 11, 2011
    Messages:
    14,994
    Location:
    Je m'en fous!
  14. Jan 1, 2017
    #14

    LuisNaniencia Sky Sports called my bluff

    Joined:
    May 22, 2010
    Messages:
    7,137
    Location:
    271.5 miles from Old Trafford
    Also had similar issue with my phone. (Android)
  15. Jan 2, 2017
    #15

    VP Full Member

    Joined:
    May 19, 2006
    Messages:
    10,787
    Yep..same issues on my chrome.
  16. Jan 2, 2017
    #16

    kr0nix Full Member

    Joined:
    Jan 29, 2011
    Messages:
    773
    I found that going into one of the match threads allows me to access the login page (www.redcafe.net/login) which I couldn't from the home page.
  17. Jan 2, 2017
    #17

    JezChan Full Member

    Joined:
    Feb 16, 2008
    Messages:
    3,369
    Location:
    Australia
  18. Jan 2, 2017
    #18

    Niall All Powerful Super Being

    Joined:
    Jun 13, 1999
    Messages:
    14,355
    To confirm, this is the login link at the very top of every page?
  19. Jan 2, 2017
    #19

    JezChan Full Member

    Joined:
    Feb 16, 2008
    Messages:
    3,369
    Location:
    Australia
    Yes - the "log in or sign up" link at the top right corner wasn't working for me.
  20. Jan 2, 2017
    #20

    Moonred Full Member

    Joined:
    Nov 15, 2012
    Messages:
    8,843
    Location:
    Virgo Supercluster
    Can't log in through safari on my iPad. Chrome was working fine on the Mac.
  21. Jan 2, 2017
    #21

    Niall All Powerful Super Being

    Joined:
    Jun 13, 1999
    Messages:
    14,355
    I can't reproduce this is in any browser but I'm still trying to narrow down the cause.

    Can people with this problem confirm if it happens in browsers they don't normally use?

    E.g. If you use Chrome, try with Firefox or Safari.
  22. Jan 2, 2017
    #22

    Stobzilla Official Team Perv

    Joined:
    Jun 7, 2004
    Messages:
    17,564
    Location:
    Grove Street, home.
    Always one.
  23. Jan 2, 2017
    #23

    diarm Full Member

    Joined:
    Jul 13, 2014
    Messages:
    6,939
    Location:
    Cork
    I've the same issue on Chrome for android but when I tried the Chrome Develope browser it logged in fine. I'm also logged in fine on Chrome for Mac and just tried with both Firefox and Safari which logged in perfectly.
  24. Jan 2, 2017
    #24

    JezChan Full Member

    Joined:
    Feb 16, 2008
    Messages:
    3,369
    Location:
    Australia
    It's happened to me on Firefox (what I normally use), but not on Chrome.
  25. Jan 2, 2017
    #25

    LuisNaniencia Sky Sports called my bluff

    Joined:
    May 22, 2010
    Messages:
    7,137
    Location:
    271.5 miles from Old Trafford
    Chrome on my android phone now working. Before it logged me out for some reason and the log in link just refreshed the page and didn't allow me to login.
  26. Jan 2, 2017
    #26

    Niall All Powerful Super Being

    Joined:
    Jun 13, 1999
    Messages:
    14,355
    I'm still pretty sure this is a caching issue. I've forced reloading of the XenForo javascript for everybody next time they load a page on the site, so please let me know if that makes a difference.

    If not, I'll try the next thing.
  27. Jan 2, 2017
    #27

    dwd Saturday Night Spies

    Joined:
    Jan 16, 2012
    Messages:
    7,287
    Location:
    Under soil heating.
    Also been having this problem the past couple of days (FF 50.01, Mac). It works on Safari desktop and iOS.
  28. Jan 2, 2017
    #28

    dwd Saturday Night Spies

    Joined:
    Jan 16, 2012
    Messages:
    7,287
    Location:
    Under soil heating.
    I just cleared my cache and tried it again, it just seems to be timing out now.
  29. Jan 2, 2017
    #29

    Niall All Powerful Super Being

    Joined:
    Jun 13, 1999
    Messages:
    14,355
    Timing out as in you get an error in your browser saying the page timed out, or nothing happens at all?
  30. Jan 2, 2017
    #30

    dwd Saturday Night Spies

    Joined:
    Jan 16, 2012
    Messages:
    7,287
    Location:
    Under soil heating.
    It starts off as if it's going to load (takes around 5 mins) then nothing happens. I've tried it on another machine with same browser and version and the same thing happens.
  31. Jan 2, 2017
    #31

    dwd Saturday Night Spies

    Joined:
    Jan 16, 2012
    Messages:
    7,287
    Location:
    Under soil heating.
    Weirdly, redcafe.net/login just redirects to redcafe.net if I try to type in manually
  32. Jan 2, 2017
    #32

    Niall All Powerful Super Being

    Joined:
    Jun 13, 1999
    Messages:
    14,355
    Any difference now @dwd?
  33. Jan 2, 2017
    #33

    Niall All Powerful Super Being

    Joined:
    Jun 13, 1999
    Messages:
    14,355
    If anyone else has this problem and can't post in this thread, please private message me.
  34. Jan 2, 2017
    #34

    dwd Saturday Night Spies

    Joined:
    Jan 16, 2012
    Messages:
    7,287
    Location:
    Under soil heating.
    It's working for me now. Sending this from FF.
  35. Jan 2, 2017
    #35

    fishfingers15 Contributes to username and tagline changes

    Joined:
    Jan 17, 2009
    Messages:
    22,303
    Location:
    YESHHHHH, We'll GOOO for it.
    I had the same issue with chrome. Cleared cookies and it was back to normal and could log on.
  36. Jan 2, 2017
    #36

    Niall All Powerful Super Being

    Joined:
    Jun 13, 1999
    Messages:
    14,355
    Thanks @fishfingers15

    Can anyone else having this issue please logout and then back in again.

    That should sort it.
  37. Jan 2, 2017
    #37

    Moonred Full Member

    Joined:
    Nov 15, 2012
    Messages:
    8,843
    Location:
    Virgo Supercluster
    The only place where I can't login is on safari on my iPad. It had mostly timed out since I haven't used the ipad for over a week. I haven't been logged out of any other devices where I am logged in. Looks like a generic login issue due to some recent changes? Also, tapping any of the 'you must login..' Links just refreshes to the unlogged in home page rather than taking me to log in UI.
  38. Jan 2, 2017
    #38

    fishfingers15 Contributes to username and tagline changes

    Joined:
    Jan 17, 2009
    Messages:
    22,303
    Location:
    YESHHHHH, We'll GOOO for it.
    Try clearing cookies for redcafe in your safari if it allows you?
  39. Jan 2, 2017
    #39

    Niall All Powerful Super Being

    Joined:
    Jun 13, 1999
    Messages:
    14,355
    Can you log out and back in again and see if that fixes it?
  40. Jan 2, 2017
    #40

    Moonred Full Member

    Joined:
    Nov 15, 2012
    Messages:
    8,843
    Location:
    Virgo Supercluster
    I could but it would delete history and other browser data as well. Thus, not doing it as I can use the phone or the computer for Caf.